DFN-CERT Portal

Schwachstellen

DFN-CERT-2017-1998: PostgreSQL: Mehrere Schwachstellen ermöglichen u.a. die Manipulation von Dateien

Historie

Version 1 (2017-11-10 13:40)
Neues Advisory
Version 2 (2017-11-14 15:05)
Canonical stellt für Ubuntu Linux 14.04 LTS, 16.04 LTS, 17.04 und 17.10 Sicherheitsupdates für die dort eingesetzten Versionszweige von PostgreSQL bereit, mit denen die Schwachstellen CVE-2017-15098 und CVE-2017-15099 behoben werden. Ubuntu Linux 14.04 LTS ist von CVE-2017-15099 nicht betroffen.

Betroffene Software

PostgreSQL < 9.2.24
PostgreSQL < 9.3.20
PostgreSQL < 9.4.15
PostgreSQL < 9.5.10
PostgreSQL < 9.6.6
PostgreSQL < 10.1

Betroffene Plattformen

macOS
Canonical Ubuntu Linux 14.04 LTS
Canonical Ubuntu Linux 16.04 LTS
Canonical Ubuntu Linux 17.04
Canonical Ubuntu Linux 17.10
Debian Linux 8.9 Jessie
Debian Linux 9.2 Stretch
FreeBSD
GNU/Linux
Microsoft Windows
OpenBSD
Oracle Solaris
Red Hat Fedora 25
Red Hat Fedora 26
Red Hat Fedora 27

Lösung

Patch

Debian Security Advisory DSA-4027-1 (postgresql-9.4)

Patch

Debian Security Advisory DSA-4028-1 (postgresql-9.6)

Patch

Fedora Security Update FEDORA-2017-0188f21212 (Fedora 25, postgresql-9.5.10-1.fc25)

Patch

Fedora Security Update FEDORA-2017-1f1fdab532 (Fedora 26, postgresql-9.6.6-1.fc26)

Patch

Fedora Security Update FEDORA-2017-783a436ee8 (Fedora 27, postgresql-9.6.6-1.fc27)

Patch

PostgreSQL 10.1 Release Notes

Patch

PostgreSQL 9.2.24 Release Notes

Patch

PostgreSQL 9.3.20 Release Notes

Patch

PostgreSQL 9.4.15 Release Notes

Patch

PostgreSQL 9.5.9 Release Notes

Patch

PostgreSQL 9.6.6 Release Notes

Patch

Ubuntu Security Notice USN-3479-1

Beschreibung

Eine Schwachstelle in PostgreSQL ermöglicht einem entfernten, nicht authentisierten Angreifer die Manipulation von allen Dateien des Systems. Zwei weitere Schwachstellen ermöglichen einem entfernten, einfach authentisierten Angreifer die Durchführung eines Denial-of-Service-Angriffs und möglicherweise das Ausspähen von Informationen sowie das Umgehen von Sicherheitsvorkehrungen.

Der Hersteller bietet die Versionen 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 und 9.2.24 von PostgreSQL an, um die Schwachstellen zu beheben. Die Version 9.2.24 ist die voraussichtlich letzte Veröffentlichung für diesen Versionszweig.

Für Fedora 25, 26 und 27 stehen Sicherheitsupdates in Form der Pakete 'postgresql-9.5.10-1.fc25', 'postgresql-9.6.6-1.fc26' und 'postgresql-9.6.6-1.fc27' an. Das Update für Fedora 27 befindet sich bereits im Status 'testing', während die anderen Updates noch den Status 'pending' besitzen.

Debian stellt Sicherheitsupdates für die alte stabile Distribution (Jessie) und für die stabile Distribution (Stretch) in den Versionen '9.4.15-0+deb8u1' und '9.6.6-0+deb9u1' bereit.

Schwachstellen

CVE-2017-15099: Schwachstelle in PostgreSQL ermöglicht Umgehen von Sicherheitsvorkehrungen

In der Implementierung der 'INSERT ... ON CONFLICT DO UPDATE'-Anweisung von PostgreSQL werden 'SELECT'-Rechte und -Richtlinien unter bestimmten Bedingungen nicht korrekt umgesetzt. Ein entfernter, einfach authentisierter Angreifer kann Sicherheitsvorkehrungen umgehen.

CVE-2017-15098: Schwachstelle in PostgreSQL ermöglicht Denial-of-Service-Angriff

In den Funktionen 'json_populate_recordset' und 'jsonb_populate_recordset' in PostgreSQL wird der Typ des Ergebnisses einer 'FROM ... AS'-Anweisung benutzt, ohne zu überprüfen, ob er mit dem tatsächlichen Reihen-Typ des angegebenen Tupels übereinstimmt. Falls die Typen verschieden sind, kann es zum Programmabsturz oder möglicherweise zur Offenlegung von Speicher des Servers kommen. Ein entfernter, einfach authentisierter Angreifer kann einen Denial-of-Service-Angriff durchführen und möglicherweise Informationen ausspähen.

CVE-2017-12172: Schwachstelle in PostgreSQL ermöglicht Manipulation von Dateien

Beispielskripte für das Starten des Servers in PostgreSQL öffnen die Postmaster-Protokolldatei mit den Rechten des Administratorbenutzers 'root', wodurch der Besitzer einer Datenbank mit Hilfe einer symbolischen Dateiverknüpfung zu beliebigen Dateien des Systems diese durch angehängte Protokolldaten zerstören kann. Diese Beispielskripte werden nicht durch PostgreSQL installiert. Der Hersteller stuft die Schwachstelle mit der höchsten Kategorie 'A' ein, die für die Eskalation von Privilegien ohne vorherigen Login steht. Ein entfernter, nicht authentisierter Angreifer kann demnach Dateien manipulieren.

Referenzen

© DFN-CERT Services GmbH, all rights reserved!
Die Weiterverbreitung ist mit Hinweis auf den Copyrightinhaber innerhalb der eigenen Einrichtung erlaubt. Eine darüber hinausgehende Verbreitung bedarf des schriftlichen Einverständnisses des Rechteinhabers.